Gcode preview looks wrong in Ubuntu

Discussions about ideaMaker and other printing software.
schuema
Posts: 5
Joined: Tue Feb 05, 2019 4:14 pm

Re: Gcode preview looks wrong in Ubuntu

Postby schuema » Tue Feb 05, 2019 4:18 pm

Hello,

I've the same problem. Did anyone find a solution. I use also Ubuntu 18.04.1

Thank's for the great slicer.

Best regards
schuema

schuema
Posts: 5
Joined: Tue Feb 05, 2019 4:14 pm

Re: Gcode preview looks wrong in Ubuntu

Postby schuema » Thu Feb 28, 2019 7:38 am

I'm sad there is no solution for Linux Users since all the years, more then a year. Is there a new release in plan? I'm very happy with your slicer, it makes a great job but a good preview is necessary to avoid errors before print.

User avatar
Vicky@Raise3D
Posts: 4947
Joined: Fri Mar 25, 2016 3:54 am

Re: Gcode preview looks wrong in Ubuntu

Postby Vicky@Raise3D » Fri Mar 01, 2019 12:11 am

We are so sorry about the trouble. We do have tested on a few Linux computer we have on computer, but unfortunately we can't recreate the same issue to debug.
Would you mind to provide us the configuration of your computer? You can find some graphic card and driver information from the following link: https://askubuntu.com/questions/28033/h ... eo-drivers
Thanks for your support!

troelff
Posts: 2
Joined: Sun Aug 26, 2018 9:26 am

Re: Gcode preview looks wrong in Ubuntu

Postby troelff » Mon Mar 04, 2019 2:19 pm

Code: Select all

> $ lspci -k | grep -EA3 'VGA|3D|Display'

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
        Subsystem: Lenovo 4th Gen Core Processor Integrated Graphics Controller
        Kernel driver in use: i915
        Kernel modules: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GK106GLM [Quadro K2100M] (rev a1)
        Subsystem: Lenovo GK106GLM [Quadro K2100M]
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
       
$ lsmod | grep "kms\|drm"
nvidia_drm             40960  19
nvidia_modeset       1085440  51 nvidia_drm
drm_kms_helper        172032  2 nvidia_drm,i915
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
fb_sys_fops            16384  1 drm_kms_helper
drm                   401408  21 drm_kms_helper,nvidia_drm,i915

Fred Bastl
Posts: 1
Joined: Mon Mar 04, 2019 6:08 pm

Re: Gcode preview looks wrong in Ubuntu

Postby Fred Bastl » Mon Mar 04, 2019 6:20 pm

Same issue for me on Mint Linux on Dell XPS 9370 with i7 processor with internal gpu and 16BG ram.

I like this slicer a lot. Please fix this annoying issue soon.

Best regards,
Fred
--------------------

This is my configuration:
VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07)

drm_kms_helper 172032 1 i915
syscopyarea 16384 1 drm_kms_helper
sysfillrect 16384 1 drm_kms_helper
sysimgblt 16384 1 drm_kms_helper
fb_sys_fops 16384 1 drm_kms_helper
drm 458752 10 drm_kms_helper,i915

/dev/fb0
/dev/dri/card0
/dev/dri/renderD128

BOOT_IMAGE=/@/boot/vmlinuz-4.18.0-15-generic root=UUID=[deleted] ro rootflags=subvol=@ quiet splash vt.handoff=1

/etc/modprobe.d/
/etc/modprobe.d/alsa-base.conf
/etc/modprobe.d/blacklist-ath_pci.conf
/etc/modprobe.d/blacklist-firewire.conf
/etc/modprobe.d/blacklist-framebuffer.conf
/etc/modprobe.d/blacklist-modem.conf
/etc/modprobe.d/blacklist-oss.conf
/etc/modprobe.d/blacklist-rare-network.conf
/etc/modprobe.d/dkms.conf
/etc/modprobe.d/iwlwifi.conf
/etc/modprobe.d/amd64-microcode-blacklist.conf
/etc/modprobe.d/intel-microcode-blacklist.conf
/etc/modprobe.d/blacklist.conf

# modprobe information used for DKMS modules
#
# This is a stub file, should be edited when needed,
# used by default by DKMS.

/etc/X11/xorg.conf - file does not exist

direct rendering: Yes
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
Vendor: Intel Open Source Technology Center (0x8086)
OpenGL vendor string: Intel Open Source Technology Center

[ 5.380] (II) LoadModule: "glx"
[ 5.486] (II) LoadModule: "modesetting"
[ 5.486] (II) LoadModule: "fbdev"
[ 5.486] (II) LoadModule: "vesa"
[ 5.512] (II) LoadModule: "fbdevhw"
[ 5.513] (II) LoadModule: "glamoregl"
[ 5.582] (II) LoadModule: "fb"
[ 5.732] (II) LoadModule: "libinput"

Ruud
Posts: 1
Joined: Fri Mar 08, 2019 3:40 pm

Re: Gcode preview looks wrong in Ubuntu

Postby Ruud » Fri Mar 08, 2019 4:13 pm

First of all, thanks you and your team for this excellent software. I've put all the slicers i have had in the bin and work yet only with yours.
BUT :) i have the same problem as mansioned above.
One thing i know for shure, the Gcode is not the problem.
When i have sliced a .stl and load this code in Repetier, that is the program i use for printing, the Gcode shows nice and well in that progam. The printing result is very, very good.
I.m using Ubuntu 18.04, fresh installed. For the Repetier sotware to run i use MONO.

Here are the spec's of the hardware i use:
CPU : Intel (R) Celeron(R) CPU 3965U @ 2.20 GHz x 2
Grapish ; Intel HD Graphics 610 (Kaby Lake GT1)
Memory Ram: 3,8 GiB
Monitor 1: Medion 24" 1920 X 1080
Monitor 2: Ilyama 24" 1920 X 1080. (This monitor shows Ideamaker.)

System Ubuntu 18.04 LTS, Gnome 3.28.2.

I really hope you find a solution for this problem. Now i have to load the Gcode after slicing in the Repetier software for the slice preview and checks. I would be nicer if i could check the slice result right away in the slice-preview of Ideamaker.

Thanks for all the effort you and your team already put in to this problem.

schuessm71
Posts: 2
Joined: Tue Mar 12, 2019 7:13 am

Re: Gcode preview looks wrong in Ubuntu

Postby schuessm71 » Wed Mar 13, 2019 1:36 pm

Vicky@Raise3D wrote:We are so sorry about the trouble. We do have tested on a few Linux computer we have on computer, ...


Can you give the information of Linux versions of yur Testcomputer, perhaps with the hardware spezifikations?

schuema
Posts: 5
Joined: Tue Feb 05, 2019 4:14 pm

Re: Gcode preview looks wrong in Ubuntu

Postby schuema » Wed Mar 13, 2019 5:39 pm

Vicky@Raise3D wrote:We are so sorry about the trouble. We do have tested on a few Linux computer we have on computer, but unfortunately we can't recreate the same issue to debug.
Would you mind to provide us the configuration of your computer? You can find some graphic card and driver information from the following link: https://askubuntu.com/questions/28033/h ... eo-drivers
Thanks for your support!

Code: Select all

max@linux:~$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Oland PRO [Radeon R7 240/340]
max@linux:~$ lsmod | grep "kms\|drm"
drm_kms_helper        180224  2 amdgpu,radeon
drm                   479232  20 gpu_sched,drm_kms_helper,amdgpu,radeon,ttm
fb_sys_fops            16384  1 drm_kms_helper
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
max@linux:~$ find /dev -group video
/dev/fb0
/dev/dri/card0
/dev/dri/renderD128
find: ‘/dev/vboxusb’: Keine Berechtigung
max@linux:~$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.0.0-050000-generic root=UUID=b1e64f28-10a1-41fc-9c97-a604997f41e4 ro console=tty1 console=ttyS0 panic=-1
max@linux:~$ find /etc/modprobe.d/
/etc/modprobe.d/
/etc/modprobe.d/blacklist-oss.conf
/etc/modprobe.d/blacklist-ath_pci.conf
/etc/modprobe.d/amd64-microcode-blacklist.conf
/etc/modprobe.d/iwlwifi.conf
/etc/modprobe.d/intel-microcode-blacklist.conf
/etc/modprobe.d/ubuntu-core-config-blacklist.conf
/etc/modprobe.d/blacklist-rare-network.conf
/etc/modprobe.d/blacklist-framebuffer.conf
/etc/modprobe.d/blacklist-firewire.conf
/etc/modprobe.d/blacklist-modem.conf
/etc/modprobe.d/blacklist.conf
/etc/modprobe.d/dkms.conf
/etc/modprobe.d/alsa-base.conf
max@linux:~$ cat /etc/modprobe.d/*kms*
# modprobe information used for DKMS modules
#
# This is a stub file, should be edited when needed,
# used by default by DKMS.
max@linux:~$ ls /etc/X11/xorg.conf
/etc/X11/xorg.conf
max@linux:~$ glxinfo | grep -i "vendor\|rendering"
direct rendering: Yes
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
    Vendor: X.Org (0x1002)
OpenGL vendor string: X.Org
max@linux:~$ grep LoadModule /var/log/Xorg.0.log
grep: /var/log/Xorg.0.log: Datei oder Verzeichnis nicht gefunden


schuema
Posts: 5
Joined: Tue Feb 05, 2019 4:14 pm

Re: Gcode preview looks wrong in Ubuntu

Postby schuema » Thu Mar 14, 2019 7:54 pm

Now I checked again. The problem ist not the language setting. The problem is the language special formats. I've the interface switched to english and now the formats to german and I've the problem again. But when I switch back to english too, it works. Perhaps it helps to correct the error at the software.

schuema
Posts: 5
Joined: Tue Feb 05, 2019 4:14 pm

Re: Gcode preview looks wrong in Ubuntu

Postby schuema » Thu Mar 14, 2019 7:59 pm

the problem ist the number format:

English: 1,000,000.00€
German: 1.000.000,00€

Perhaps you can correct it with the next release.

User avatar
Vicky@Raise3D
Posts: 4947
Joined: Fri Mar 25, 2016 3:54 am

Re: Gcode preview looks wrong in Ubuntu

Postby Vicky@Raise3D » Fri Mar 15, 2019 5:20 am

Thanks a lot for your efforts!
We think we may find out the reason is causing the issue now. We will fix the issue we found in next release.

User avatar
Vicky@Raise3D
Posts: 4947
Joined: Fri Mar 25, 2016 3:54 am

Re: Gcode preview looks wrong in Ubuntu

Postby Vicky@Raise3D » Fri Mar 15, 2019 5:36 am

As a temporary solution for the issue, if the preview issue really brothers your work a lot, please change language region formats to be English. We are using 14.04 system, we get the option under language support.


Return to “Software”

Who is online

Users browsing this forum: No registered users and 2 guests