Weird support behaviour with ideaMaker 3.4.0 Beta

Discussions about ideaMaker and other printing software.
tja
Posts: 135
Joined: Mon Oct 17, 2016 10:24 pm
Location: Essex, UK

Weird support behaviour with ideaMaker 3.4.0 Beta

Postby tja » Fri May 17, 2019 8:15 pm

Hi Vicky,

Just started to print a model with supports, which I very rarely have to do. Depending on the direction I lay the model on the bed, the support structure changes orientation. At 0 or 90 degrees Z rotation all the support gets laid down as continuous lines, this is good. But if I slice it at 45 degrees Z rotation I get a lot of little pieces of support laid down, which of course doesn't hold on the bed very well. After a few layers there were big holes in it and I had to stop the print!!

Also, I noticed that sometimes the first bottom layer, laid down on the supports, is actually aligned with the support lines. This means that it isn't actually getting much benefit from the support material.

Is this typical behaviour when printing support structures, or is it a bug with 3.4.0?

I have attached some screen shots
Attachments
first bottom layer.PNG
0 degrees.PNG
45 degrees.PNG

User avatar
Vicky@Raise3D
Posts: 5170
Joined: Fri Mar 25, 2016 3:54 am

Re: Weird support behaviour with ideaMaker 3.4.0 Beta

Postby Vicky@Raise3D » Sat May 18, 2019 1:41 am

Would you like to share gcode, idea and data files with us?

tja
Posts: 135
Joined: Mon Oct 17, 2016 10:24 pm
Location: Essex, UK

Re: Weird support behaviour with ideaMaker 3.4.0 Beta

Postby tja » Mon May 20, 2019 11:57 am

No problem Vicky, files attached

I added a brim for my second print, which printed fine at Z = 0 degrees. However, when I rotated the model 45 degrees Z to slice and send you the files, I noticed it now makes a wavy brim!

I checked this effect on two older models, using different filament templates and I see exactly the same weird support behaviour. It's most pronounced at Z = 45 degrees, but usually you can start to see it from about 30 degrees
Attachments
TV Bracket cover v4.idea
(330.42 KiB) Downloaded 3 times
TV Bracket cover v4.gcode
(3.19 MiB) Downloaded 3 times
TV Bracket cover v4.data
(49.91 KiB) Downloaded 2 times
TV Bracket cover v4.stl
(178.79 KiB) Downloaded 2 times

User avatar
Vicky@Raise3D
Posts: 5170
Joined: Fri Mar 25, 2016 3:54 am

Re: Weird support behaviour with ideaMaker 3.4.0 Beta

Postby Vicky@Raise3D » Tue May 21, 2019 12:04 am

If you rotate your model after generating the support structures, you may need to generate supports one more time based on the new position of your model.

tja
Posts: 135
Joined: Mon Oct 17, 2016 10:24 pm
Location: Essex, UK

Re: Weird support behaviour with ideaMaker 3.4.0 Beta

Postby tja » Tue May 21, 2019 9:57 am

Thanks Vicky, that seems to fix the problem. Rotating the part before creating the supports gives nice straight support lines. Ideally IM would popup a warning message to the user, if the model is rotated after supports have been added.

User avatar
Vicky@Raise3D
Posts: 5170
Joined: Fri Mar 25, 2016 3:54 am

Re: Weird support behaviour with ideaMaker 3.4.0 Beta

Postby Vicky@Raise3D » Tue May 21, 2019 5:36 pm

Thanks for your suggestion. We will try to see whether we can have ideaMaker update Support Generation together Model Rotation in future updates.
And we will also consider to add an option to identify the first layer after support is Solid Fill or Bridging.
You can set different Solid Fill angle values for Top and Down Solid Fill Angle to separate it from Support Angle.
With the current version of ideaMaker you are using, you can check whether the layer after support is Bridging or Solid Fill. If it is Bridging, you can edit the Bridging Angle under Other to make it be different from Support Angle.

tja
Posts: 135
Joined: Mon Oct 17, 2016 10:24 pm
Location: Essex, UK

Re: Weird support behaviour with ideaMaker 3.4.0 Beta

Postby tja » Thu May 23, 2019 2:14 pm

Okay, thanks for the info


Return to “Software”

Who is online

Users browsing this forum: No registered users and 1 guest