My printer connects, but refuses to accept uploads

Discussions about ideaMaker and other printing software.
User avatar
toddanglin
Posts: 5
Joined: Mon May 10, 2021 3:37 am

Re: My printer connects, but refuses to accept uploads

Postby toddanglin » Tue May 11, 2021 9:58 pm

Good to know, Vicky. Thanks for the reply. (And I must say, if this is not a shared support account, you are amazingly prolific and prompt on these forums. :))

Meanwhile, the printer seems to be back in business. It is accepting uploads over both the local network and from RaiseCloud. I did unbind/rebind the printer to RaiseCloud to get it out of "Offline" status, but other than that, the problem seems to be ephemeral (for better and worse). If it happens again, I'll try to further diagnose what may be causing the problem.

Meanwhile, a feature request: it would be great if there were an option in RaiseCloud to manually poll a printer to refresh the status so that a printer restart or bind/unbind isn't necessary to resolve temporary "Offline" network issues like this.

User avatar
Vicky@Raise3D
Posts: 8055
Joined: Fri Mar 25, 2016 3:54 am

Re: My printer connects, but refuses to accept uploads

Postby Vicky@Raise3D » Wed May 12, 2021 2:07 am

Thanks for your suggestions! We will add your request into developing list.

Jeff_Birt
Posts: 33
Joined: Fri Apr 23, 2021 2:20 pm

Re: My printer connects, but refuses to accept uploads

Postby Jeff_Birt » Wed May 12, 2021 1:14 pm

When I first got my E2 I was having a lot of issues with not being able to upload over WiFi. Given that the printer is within 2M of the router I knew it was not a signal strength issue. I also noticed that my router would show a connection to the printer at times when the printer thought there was no connection.

I finally disabled Wi-Fi at the printer and then after several seconds enabled it again. Since that time I have had only an occasional failed upload. Why would disabling/enabling the Wi-Fi on the printer work? It could be that the disable/enable procedure causes some initialization to take place, something that would not normally be done via a power cycle. It might also just be a coincidence. Either way it only takes a minute to give it a try.

Raise3D_User1
Posts: 70
Joined: Fri May 15, 2020 2:05 am

Re: My printer connects, but refuses to accept uploads

Postby Raise3D_User1 » Thu May 13, 2021 6:56 pm

Updated to Ideamaker 4.1.1 and now I have this issue as well. Stuck on "waiting" forever on an E2 (EDIT: It won't upload to ANY of my 3 E2 machines now, so it has to be on the software and not the machine(s)). All of them work with the remote app fine.

I rebooted, reloaded ideamaker, changed from 2.4 to 5Ghz wireless, gave up on wireless and directly connected to wired ethernet with a static IP. Nothing helps.

I can ping the printers and get responses fine, and the remote window is responsive. I just can't upload. It's there and I can interact with it. I just can't get ideamaker to upload to it now.

User avatar
Vicky@Raise3D
Posts: 8055
Joined: Fri Mar 25, 2016 3:54 am

Re: My printer connects, but refuses to accept uploads

Postby Vicky@Raise3D » Fri May 14, 2021 1:44 am

Please help double cofnirm that the uploading target IP address is the same as remotr control address.
The port is 31626, TCP. Please also make sure the port is not blocked by firewall.

Raise3D_User1
Posts: 70
Joined: Fri May 15, 2020 2:05 am

Re: My printer connects, but refuses to accept uploads

Postby Raise3D_User1 » Fri May 14, 2021 3:56 am

Nope. No joy.

The IP address displayed beneath the name of each printer on the remote window is the same as the IP address in the ethernet panel of the E2 machines (I'm not using wireless at all now to eliminate one more potential point of failure).

Adding the port to the firewall as trusted made no difference. This USED TO work, even shortly after I installed 4.1.1 I was able to upload (though it would occasionally hang, I would just cancel and re-do the upload and it finished). It just quit working completely today for all three at the same time. But all other network functions (remote control panel, pings, online updater, everything) works fine.

Also, just to be sure, I disabled the antivirus/firewall completely and no upload works to any machine, still.

EDIT: I also tried to downgrade to the last version and the problem remains. I have re-upgraded to 4.1.1 since.

User avatar
Vicky@Raise3D
Posts: 8055
Joined: Fri Mar 25, 2016 3:54 am

Re: My printer connects, but refuses to accept uploads

Postby Vicky@Raise3D » Tue May 18, 2021 6:59 pm

We have generated a beta version ideaMaker which can show more information of the error in uploading queue. Let me know if you have interest in helping us test the issue.

Raise3D_User1
Posts: 70
Joined: Fri May 15, 2020 2:05 am

Re: My printer connects, but refuses to accept uploads

Postby Raise3D_User1 » Wed May 26, 2021 3:49 am

Vicky@Raise3D wrote:We have generated a beta version ideaMaker which can show more information of the error in uploading queue. Let me know if you have interest in helping us test the issue.


Yes, thank you. I came back to post that support sent me a version of the ideamaker that gave them more information about the problem, then sent a beta version of raise touch that corrected the issue and now I am able to send the files over the wire and wireless network again.

Thanks!

Raise3D_User1
Posts: 70
Joined: Fri May 15, 2020 2:05 am

Re: My printer connects, but refuses to accept uploads

Postby Raise3D_User1 » Fri May 28, 2021 3:27 am

Problem's back. Can't upload to any of the printers again. HOWEVER, I think I know what happened this time.

When uploading a file, I put "255/260/80" at the end of the file name for the model so I would know the temps for that version. Raise uploaded the file as "80" - it truncated everything before the "/" likely because it's a special character. So the field where you can name the file you're uploading doesn't have a filter to disallow special characters and those characters ( in this case a "/") can freak out the software, apparently gumming up the queue.

I've passed this info to E2 support, now I just need to try re-flashing raisetouch to see if it unclogs the queue like it did last time.

User avatar
Vicky@Raise3D
Posts: 8055
Joined: Fri Mar 25, 2016 3:54 am

Re: My printer connects, but refuses to accept uploads

Postby Vicky@Raise3D » Sat May 29, 2021 3:31 am

The issue has been submitted to developing team and it is currently under review. We will fix it as soon as possible.

User avatar
Vicky@Raise3D
Posts: 8055
Joined: Fri Mar 25, 2016 3:54 am

Re: My printer connects, but refuses to accept uploads

Postby Vicky@Raise3D » Tue Jun 01, 2021 9:32 pm

We have figured out the problem and can generate a beta version for you if you'd like to help us test.

Raise3D_User1
Posts: 70
Joined: Fri May 15, 2020 2:05 am

Re: My printer connects, but refuses to accept uploads

Postby Raise3D_User1 » Wed Jun 02, 2021 10:17 pm

Vicky@Raise3D wrote:We have figured out the problem and can generate a beta version for you if you'd like to help us test.


They sent me a link with the version that disallows special characters. I'll install it tonight.


Return to “Software”

Who is online

Users browsing this forum: No registered users and 1 guest