BUG : loss origins in the rotations of aligned models

Discussions about ideaMaker and other printing software.
IMDIMA
Posts: 11
Joined: Tue Aug 23, 2016 12:02 pm

BUG : loss origins in the rotations of aligned models

Postby IMDIMA » Thu Sep 22, 2016 1:50 pm

For two-color printing, after loading two 3D models I select the two and "move" and "align together"

Then if I want to rotate the two pieces (selected simultaneously and / or separately) for easy printing the alignment of origins is lost.
Even if I trie to repeat the alignment in this new position that does not work

I has also tried to make first rotations on 2 models and align origins after but it did not work either

The possibility to create a group with two loaded models and apply to that group all possible transformations would be a great help

(sorry for my bad english i'm so french ! haha !)

Online
User avatar
Vicky@Raise3D
Posts: 5611
Joined: Fri Mar 25, 2016 3:54 am

Re: BUG : loss origins in the rotations of aligned models

Postby Vicky@Raise3D » Fri Sep 23, 2016 4:28 am

Select both model. Then choose Model -> Merge Selected Models.
2.png

The two models will be one group.
3.png

You can rotate or move them. They will move together.
4.png

If you want to let them to be separate, you can choose Model -> Auto Ungroup.
5.png

Then you can move them separately.
6.png

IMDIMA
Posts: 11
Joined: Tue Aug 23, 2016 12:02 pm

Re: BUG : loss origins in the rotations of aligned models

Postby IMDIMA » Fri Sep 23, 2016 6:58 am

Thank You for your quick and documented answer

If I use "Auto Ungroup" after "Merge selected models" and "move/rotate them together" as you told me I often find myself with more than two models.

I must then remerge the right pieces together in order to assign each model from the extruder corresponding to it, it's tedious!

I return to my original question: Why after "align together" we lose this alignment during rotations? If this could be changed would bring much comfort to the management of two colors prints


-thank you-

Online
User avatar
Vicky@Raise3D
Posts: 5611
Joined: Fri Mar 25, 2016 3:54 am

Re: BUG : loss origins in the rotations of aligned models

Postby Vicky@Raise3D » Fri Sep 23, 2016 7:23 am

Alignment is just commend of adjusting position which has the same priority of Move and Rotate. So the command you select after will be carried out directly. They don't have limitation to each other.

I recommend you to choose the nozzle after completing the position adjusting.

If you have more than two models at one time, there can be several groups in one slice. You don't need to select all models to merge at one time.
1.png

IMDIMA
Posts: 11
Joined: Tue Aug 23, 2016 12:02 pm

Re: BUG : loss origins in the rotations of aligned models

Postby IMDIMA » Fri Sep 23, 2016 9:07 am

Let me know if you find it easy with those 2 stl : https://we.tl/LZjn6Cit54

For exemple I want to print them upside down, one color for each file

When I "Auto Ungroup" there is 337 parts, not easy to allocate the right parts to each of the two extruders!

maybe there is a trick that I did not understand... ?

Online
User avatar
Vicky@Raise3D
Posts: 5611
Joined: Fri Mar 25, 2016 3:54 am

Re: BUG : loss origins in the rotations of aligned models

Postby Vicky@Raise3D » Fri Sep 23, 2016 10:07 am

This model seems don't need Merge.
Select both and you can rotate them together after alignment.
2.png

IMDIMA
Posts: 11
Joined: Tue Aug 23, 2016 12:02 pm

Re: BUG : loss origins in the rotations of aligned models

Postby IMDIMA » Fri Sep 23, 2016 1:34 pm

if you look more closely you'll see that the two models are no longer aligned...
and if you don't see it in this position try upside down

Online
User avatar
Vicky@Raise3D
Posts: 5611
Joined: Fri Mar 25, 2016 3:54 am

Re: BUG : loss origins in the rotations of aligned models

Postby Vicky@Raise3D » Fri Sep 23, 2016 4:10 pm

We are so sorry. The rotate function needs to be improved. The merge function is just out of expediency. We need to check whether we can make the rotate better.

IMDIMA
Posts: 11
Joined: Tue Aug 23, 2016 12:02 pm

Re: BUG : loss origins in the rotations of aligned models

Postby IMDIMA » Fri Sep 23, 2016 4:35 pm

ok, good luck for your research

if I could explain in French I could give you some ideas but in English it's very hard! sorry

Nevermind I try :
I think that just two things should be clearly separated in functions:

1 -> group / ungroup (to apply transformations to selected models such as zoom, rotate, move, align the origins)

2 -> merge / separate connected mesh (what you call now "Auto Ungroup")

Hope that help

Online
User avatar
Vicky@Raise3D
Posts: 5611
Joined: Fri Mar 25, 2016 3:54 am

Re: BUG : loss origins in the rotations of aligned models

Postby Vicky@Raise3D » Sat Sep 24, 2016 4:20 pm

Would you like to explain more details?

I'm not very clear of the difference between between 1 and 2.

User avatar
walshlg
Posts: 1350
Joined: Wed Mar 23, 2016 12:01 pm

Re: BUG : loss origins in the rotations of aligned models

Postby walshlg » Mon Sep 26, 2016 7:36 pm

One tip that can be useful if printing a set repeatedly is arrange it on the bed just how you would like then save the whole thing as an stl in ideamaker.

Online
User avatar
Vicky@Raise3D
Posts: 5611
Joined: Fri Mar 25, 2016 3:54 am

Re: BUG : loss origins in the rotations of aligned models

Postby Vicky@Raise3D » Tue Sep 27, 2016 6:55 am

ideaMaker can only save one stl one time.


Return to “Software”

Who is online

Users browsing this forum: Vicky@Raise3D and 2 guests