Z Hop bug

Discussions about ideaMaker and other printing software.
LibrePixels
Posts: 2
Joined: Fri Jan 21, 2022 9:19 pm

Z Hop bug

Postby LibrePixels » Fri Jan 21, 2022 9:30 pm

Hello,

I have problem with "Z Hop performed only at top and bottommost surfaces". I don't think this feature works the way it should. If you are using "Allow Filling Gaps using Single Extrusion Filling" Z hop is performed incorrectly on each layer.

Single extrusion filling enabled:

Image

Single extrusion filling disabled:

Image

ideaMaker version: 4.2.2.5450 Ubuntu 64bit

Thank you!
Jiri
Attachments
3DBenchy_IdeaMaker_bug.data
(92.24 KiB) Downloaded 22 times
3DBenchy_IdeaMaker_bug.gcode
(3.73 MiB) Downloaded 18 times

User avatar
Vicky@Raise3D
Posts: 8509
Joined: Fri Mar 25, 2016 3:54 am

Re: Z Hop bug

Postby Vicky@Raise3D » Mon Jan 24, 2022 11:51 pm

To determine whether to trigger a Top Surface Z Hop is according to whether there's Gap Filling, Top surface Layer or Top surface ironing.
Bottommost surface Z hop only will be generated when the layer is 0 and there are solid fills or gap filling.
When Single Extrusion Gap Filling disabled, the top surfaces will only have regualr gap filling with no Top Surafece Z hop.

LibrePixels
Posts: 2
Joined: Fri Jan 21, 2022 9:19 pm

Re: Z Hop bug

Postby LibrePixels » Tue Jan 25, 2022 6:38 pm

Thank you for your reply! The reason I'm addressing this setting is because when printing with PETG, stringing occurs at the Z hop. When the Z hop is triggered in the middle the model, it causes stringing issues. I only need to use Z hop to prevent scratching top layer of the model. So the solution is not to use "Single extrusion filling" at all. Is that right or am I missing something?

User avatar
Vicky@Raise3D
Posts: 8509
Joined: Fri Mar 25, 2016 3:54 am

Re: Z Hop bug

Postby Vicky@Raise3D » Wed Jan 26, 2022 12:53 am

Single extrusion filling needs to be enabled.


Return to “Software”

Who is online

Users browsing this forum: No registered users and 2 guests