Page 1 of 1

Feature Request - Disable heatup gcode warning

Posted: Sun Apr 25, 2021 12:01 am
by evolwun
It would be nice to disable this warning when there is no heatup gcode found (see attached). When running Klipper, no gcode is entered in the start gcode, only a call to a macro. I am tired of clicking yes to that warning every time I save the profile.

Re: Feature Request - Disable heatup gcode warning

Posted: Tue Apr 27, 2021 2:27 am
by Vicky@Raise3D
You can disable Insert Heatup GCode Automatically.
https://support.raise3d.com/ideaMaker/5 ... 5-445.html

Re: Feature Request - Disable heatup gcode warning

Posted: Tue May 04, 2021 8:34 pm
by evolwun
I have that disabled. What I find useless is the warning telling me that there is no heatup gcode in the start gcode. I don't want any heatup gcode, but I don't want to be bugged by an error telling me either.

Re: Feature Request - Disable heatup gcode warning

Posted: Wed May 05, 2021 6:32 pm
by Vicky@Raise3D
The temperature code check warning is to remind the users to check there's temperature code in gcode file. It can be either generated by ideaMaker or manually added into Start Gcode by user. We have seen users missig adding heating code before print starts so we added this warning.
For this printer, the heating code is controlled by firmware. We will remove it in future versions for similar types of printers.