Z Hop behaviour, possible bug?

Discussions about ideaMaker and other printing software.
tja
Posts: 152
Joined: Mon Oct 17, 2016 10:24 pm
Location: Essex, UK

Z Hop behaviour, possible bug?

Postby tja » Wed Feb 12, 2020 4:54 pm

Hi Vicky

First time I have used Z Hop and it doesn't behave how I expected. I am printing multiple small models and to get 24 on the table I can't use sequential mode. To avoid possible collisions I applied a Z Hop of 0.5 mm using the option Z Hop performed (4) 'Only across models and supports'. But I don't get any Z Hop. Similarly, if I select Z Hop performed with option (5), I get no Z Hop However, if I set it to Z Hop performed (1) 'All' then it seems to work fine, but of course it adds several minutes to the print run.

Is this a known bug or am I missing something?

User avatar
Vicky@Raise3D
Posts: 5925
Joined: Fri Mar 25, 2016 3:54 am

Re: Z Hop behaviour, possible bug?

Postby Vicky@Raise3D » Wed Feb 12, 2020 10:34 pm

Would you to share your gcode file with us? It can be related to other settings regarding to retractions or the structures of the model.

tja
Posts: 152
Joined: Mon Oct 17, 2016 10:24 pm
Location: Essex, UK

Re: Z Hop behaviour, possible bug?

Postby tja » Wed Feb 12, 2020 11:52 pm

No problem, here it is...
Last edited by tja on Tue Feb 18, 2020 5:38 pm, edited 1 time in total.

User avatar
Vicky@Raise3D
Posts: 5925
Joined: Fri Mar 25, 2016 3:54 am

Re: Z Hop behaviour, possible bug?

Postby Vicky@Raise3D » Thu Feb 13, 2020 3:15 am

I tried to dig in to your code, but I'd prefer if I can have more information from you. My bad. Would you mind share your .idea file with me together?

tja
Posts: 152
Joined: Mon Oct 17, 2016 10:24 pm
Location: Essex, UK

Re: Z Hop behaviour, possible bug?

Postby tja » Thu Feb 13, 2020 11:56 am

Here's the .idea file...
Last edited by tja on Tue Feb 18, 2020 5:37 pm, edited 1 time in total.

User avatar
Vicky@Raise3D
Posts: 5925
Joined: Fri Mar 25, 2016 3:54 am

Re: Z Hop behaviour, possible bug?

Postby Vicky@Raise3D » Fri Feb 14, 2020 7:19 pm

Try select the no.2 option under ZHop Performed, Only at Solid Parts and select Rectilinear for Top Solid Fill Pattern and Bottom Solid Fill Pattern. You should can have better result.
The no.5 option you selecte for ZHop is for avoid collision of support structures when nozzle moves among supports and models. Your model doesn't really have a lot support structures needs to use this option.

tja
Posts: 152
Joined: Mon Oct 17, 2016 10:24 pm
Location: Essex, UK

Re: Z Hop behaviour, possible bug?

Postby tja » Tue Feb 18, 2020 5:37 pm

Thanks Vicky, but option #2 only works for the lower layers of my model, where the solid fill areas are, at the top few layers it doesn't Z hop between models. This isn't a big deal when I only have 2 items on the bed, but when I have 24 I know that I do get the occasional collison, which I was trying to avoid by including a Z hop between models.

I am pretty sure there are bugs in the Z hop feature

User avatar
Vicky@Raise3D
Posts: 5925
Joined: Fri Mar 25, 2016 3:54 am

Re: Z Hop behaviour, possible bug?

Postby Vicky@Raise3D » Wed Feb 19, 2020 2:04 am

Thanks for your explanations. From what I see, the current Z hop doesn't provide an option for avoiding Collision among models. There are Z hops happening during Solid Fills on Top Layers.


Return to “Software”

Who is online

Users browsing this forum: No registered users and 3 guests