Need help with extrusion on reprap firmware

Discussions about ideaMaker and other printing software.
cullymoto
Posts: 52
Joined: Tue Jan 31, 2017 7:32 pm

Need help with extrusion on reprap firmware

Postby cullymoto » Sat Jul 20, 2019 6:07 pm

Hello community.
First off, I love ideamaker!
I've converted a modix big 60 printer to run on duet2 wifi and that board uses Reprap firmware.
Everything is good there so far, and I have calibrated steps per mm of All the steppers.

When I slice a model in ideamaker (3.4.0 I believe)
It has the extruder move a mach 6!
In firmware I've dropped the max speed of the extruder to 10mm/sec and if I could guess - ideamaker commands it to run at around 6000 mm/sec.
Any thoughts on what's going on here? Any suggestions to get it to Run at the appropriate speeds?
Is this a comparability issue with Reprap 2.x?

I cannot stand s3d ... That whole 4.0 release and the nonsense of the upcoming 5.0... I do not wish to support that software, however..
When using s3d to slice the same model I get the expected extrusion rates. (As well as all the flaws s3d is now known for like random frequent pauses)

cullymoto
Posts: 52
Joined: Tue Jan 31, 2017 7:32 pm

Re: Need help with extrusion on reprap firmware

Postby cullymoto » Sat Jul 20, 2019 6:52 pm

In comparing the two g code files ( one from IM , the other from s3d ) ideamaker ads "f2400 E0.0000" immediately before skirt instructions. S3d does not have that code.
This is setting the speed of the extruder to 2400 mm/min if I understand correctly. Exceeding my extruders max speed of 10mm/sec by a factor of 4.

I am manually deleting this line of code to see if it corrects my issue

User avatar
Vicky@Raise3D
Posts: 5632
Joined: Fri Mar 25, 2016 3:54 am

Re: Need help with extrusion on reprap firmware

Postby Vicky@Raise3D » Mon Jul 22, 2019 7:42 pm

The code you attached is for setting restart speed. There will be one retraction after completing the StartCode to move the print head to start print Skirt.

cullymoto
Posts: 52
Joined: Tue Jan 31, 2017 7:32 pm

Re: Need help with extrusion on reprap firmware

Postby cullymoto » Tue Jul 23, 2019 1:20 pm

Hi Vicky.
I gave been using IM to continue my testing of the 32 bit board.
I have to manually erase the "F2400 E-3.000"
And "F24000 E0.000"
Lines both above and below the "start :skirt" near the beginning of the g-code.
After erasing these commands in notepad++ and then uploading the file to the duet web interface, everything performs as it should.

It's there any way to get IM to stop adding those two speed settings?

cullymoto
Posts: 52
Joined: Tue Jan 31, 2017 7:32 pm

Re: Need help with extrusion on reprap firmware

Postby cullymoto » Tue Jul 23, 2019 1:21 pm

Vicky@Raise3D wrote:The code you attached is for setting restart speed. There will be one retraction after completing the StartCode to move the print head to start print Skirt.

Perhaps if I make my retract and restart speed match my firmware extruder maximum speed?
A better question maybe it's, why is ideamaker able to exceed my firmwares maximum speed settings?
I recall having to lower the Z speed in the slicer as it was also exceeding the firmware Z speed and causing my Z stage to bind up.

User avatar
Vicky@Raise3D
Posts: 5632
Joined: Fri Mar 25, 2016 3:54 am

Re: Need help with extrusion on reprap firmware

Postby Vicky@Raise3D » Wed Jul 24, 2019 3:11 am

I'm so sorry but ideaMaker can't see the limitation in firmware from a 3rd party printer.


Return to “Software”

Who is online

Users browsing this forum: No registered users and 2 guests