Page 1 of 1

Some issues with ideaMaker

Posted: Sun Jul 07, 2019 5:42 am
by nano4u
Hi,

I am using ideaMaker now for quite a while, both for professional as well as for private purposes. I must say it has quite a few advantages over other slicers. However, a few issues I could not resolve myself, so I would be happy if anyone had suggestions for solutions or workarounds:

1) Is there a way to "reload" a model, such that all transformations (rotation, scaling etc) are just kept the same? I often modify my models a little bit in order to make them more printable, but it is rather annoying that all these modifications have to be repeated then. All other slicers I know actually have this option.

2) It seems that ideaMaker always adds a GCode command to lower the bed by 5 mm, just before the user-defined end code. This often results in ugly "noses" at the end of the print because the filament is vertically pulled out of the nozzle. For fast z-stages like on the Pro2 this is less pronounced but as I am also using ideaMaker on third party printers this can literally ruin the print. It is rather annoying to always post-process the code externally. Is there a way to skip that command, or to remove it within ideaMaker?

3) The option to place the seam (start position in each layer) on a convex corner does not always work. Instead, ideaMaker often still places the seam on a reflex corner. Is that a known behavior, and is there a way to force ideaMaker to align the seam at the same (or similar) xy location?

Thanks a lot in advance for any suggestions!

Re: Some issues with ideaMaker

Posted: Wed Jul 10, 2019 12:08 am
by Vicky@Raise3D
1. The request has been added into our developing list.
2. ideaMaker doesn't support this at the moment.
3. Would you like to share the Gcode and idea files with us? You can choose Fixed and set a position for gather all the Start Points to a similar location for each layer.

Re: Some issues with ideaMaker

Posted: Thu Jul 11, 2019 5:22 pm
by nano4u
Hi Vicky,
Thanks for your response. Somehow I could not reproduce the reflex/convex issue again, although I struggled with it for quite a while :(
Maybe I messed up a reflex outer wall (wall of a hole) with the inner wall of a convex shape when using low infill (then it looks like the outer wall at a hole in the layer preview). Sorry for that, in case it reappears I will bother you again, okay? :)

Just a question regarding 2): is there a specific reason for that command? It could be easily just added within the end code, couldn't it?

Re: Some issues with ideaMaker

Posted: Fri Jul 12, 2019 1:07 am
by Vicky@Raise3D
If you meet the same issue again, please share the files with us for further test. We'd like to help test what's going on.

The reason why we raise the nozzle is trying to move the hot nozzle with filament melt inside already away from the top of the model in case melt filament leaking and left on the top of the model.
And you'd like to keep the nozzle at the last layer's height and move back to Home directly?

Re: Some issues with ideaMaker

Posted: Fri Jul 12, 2019 4:38 am
by nano4u
Actually, I found that it is much better just to move the nozzle away by one or two layer heights vertically (0.2mm or so), then quickly move x and y, e.g. to the origin. This way the hot filament is not pulled out of the nozzle but it is rather kind of sheared off. In ideaMaker I add this to the end code and delete the vertical 5mm travel move from the gcode file manually. Not very convenient but works.

Re: Some issues with ideaMaker

Posted: Sat Jul 13, 2019 4:07 am
by Vicky@Raise3D
If you can share your gcode file with us, we would like to check how we can help.

Re: Some issues with ideaMaker

Posted: Sun Jul 14, 2019 4:02 pm
by nano4u
Today I did some test prints for a direct comparison with and without z-travel move. See files attached.

The photos below show the result of two different test prints, each in two versions (thick rod / thin rod). Unchanged GCode generated by ideaMaker is on the left, the only difference on the right hand side was that I deleted the 5mm vertical travel move in the output GCode file.

Thick rod test print:
thickRod.jpg

Note the pronounced "nose" due to the effect described in the previous post, which is completely absent when quickly traveling horizontally instead of vertically.

Thin rod test print:
thinRod.jpg

The nose is even more pronounced due to hot material (bad cooling). Even then the horizontal travel helps a lot.

To be fair I must admit that these prints were done on a printer with very slow z axis (see GCode). But even on the Pro2 it makes a difference!

Maybe my claim "can ruin the print" was a bit exaggerated but since these noses can be avoided so easily, would it be possible to add some check box "omit z-travel" in the end code tab?

I added all four GCode files. "postMod" means that the z travels have been deleted.

Re: Some issues with ideaMaker

Posted: Thu Jul 18, 2019 1:09 am
by Vicky@Raise3D
Would you like to advise which operation system you are using so that we can see whether we can build a beta version for you?

Re: Some issues with ideaMaker

Posted: Thu Jul 18, 2019 6:12 am
by nano4u
Sounds very interesing! I am using Windows 10 64bit.

Re: Some issues with ideaMaker

Posted: Mon Jul 22, 2019 7:38 pm
by Vicky@Raise3D
PM sent. Please check.