Possible Bug in 3.4.1

Discussions about ideaMaker and other printing software.
Ralf95
Posts: 12
Joined: Mon May 27, 2019 6:01 pm

Possible Bug in 3.4.1

Postby Ralf95 » Mon May 27, 2019 6:20 pm

Dear Raise3D - team,

I tested 3.4 Beta and now 3.4.1.
For me it seems that there is bug in the function "avoid travelling through holes" in combination with "avoid retractions inside models".

Nozzle is moving through holes without any retraction this leads to a lot of stringing.
Version3.4.1.PNG


Slicing the same model in 3.3 leads to a good result.

Version3.3.PNG
Version3.3.PNG (55.16 KiB) Viewed 1319 times


Hope there is a solution for this because I like the new functions.
Hope this feeback helps to improve ideamaker. :)

User avatar
Vicky@Raise3D
Posts: 5510
Joined: Fri Mar 25, 2016 3:54 am

Re: Possible Bug in 3.4.1

Postby Vicky@Raise3D » Wed May 29, 2019 12:00 am

Would you like to share your gcode and idea files with us so that we can check out more details about what's going on this print?

Ralf95
Posts: 12
Joined: Mon May 27, 2019 6:01 pm

Re: Possible Bug in 3.4.1

Postby Ralf95 » Wed May 29, 2019 3:20 am

Sure, no problem.

Attached you find the idea-file, the gcodes and data-files.
Hope this helps to figure out the problem.

mfg Ralf

Testfile.idea
(84.27 KiB) Downloaded 52 times
testfile_3.3.gcode
(533.75 KiB) Downloaded 48 times
testfile_4.1.gcode
(528.94 KiB) Downloaded 60 times
testfile_3.3.data
(38.72 KiB) Downloaded 41 times
testfile_4.1.data
(42.81 KiB) Downloaded 51 times

User avatar
Vicky@Raise3D
Posts: 5510
Joined: Fri Mar 25, 2016 3:54 am

Re: Possible Bug in 3.4.1

Postby Vicky@Raise3D » Fri May 31, 2019 5:25 pm

We have just finished a beta version of ideaMaker which may can fix this issue.
If you have any interest to run test for us, please let me know.

Ralf95
Posts: 12
Joined: Mon May 27, 2019 6:01 pm

Re: Possible Bug in 3.4.1

Postby Ralf95 » Fri May 31, 2019 7:20 pm

Hello,

I can of course test the beta and give you a feedback.
Impressive how you deal with feedbacks to improve your product...

User avatar
Vicky@Raise3D
Posts: 5510
Joined: Fri Mar 25, 2016 3:54 am

Re: Possible Bug in 3.4.1

Postby Vicky@Raise3D » Fri May 31, 2019 11:44 pm

Thanks for your help. Please advise whether you are using Windows version or Mac version.
I will PM you the download link.

Ralf95
Posts: 12
Joined: Mon May 27, 2019 6:01 pm

Re: Possible Bug in 3.4.1

Postby Ralf95 » Fri Jun 07, 2019 2:01 pm

I´m using the Windows version.

User avatar
Vicky@Raise3D
Posts: 5510
Joined: Fri Mar 25, 2016 3:54 am

Re: Possible Bug in 3.4.1

Postby Vicky@Raise3D » Fri Jun 07, 2019 5:13 pm

Thanks for your help. PM sent.

Ralf95
Posts: 12
Joined: Mon May 27, 2019 6:01 pm

Re: Possible Bug in 3.4.1

Postby Ralf95 » Sun Jun 09, 2019 4:21 am

Dear Vicky,

tested and on the first view everything is again working fine.
Thanks for great support.

Ralf95
Posts: 12
Joined: Mon May 27, 2019 6:01 pm

Re: Possible Bug in 3.4.1

Postby Ralf95 » Sun Jun 09, 2019 7:23 am

Dear Vicky,

after some stress test for this function I figured out that the failure is not completely gone.
Very seldom the nozzle is travelling again through holes.

Attached you find the idea and gcode file...

20190609-091321-001.jpg

Testfile.idea
(1.95 MiB) Downloaded 40 times

Testfile.rar
(3.35 MiB) Downloaded 22 times


PS: Gcode has to be packed because of size was too big.

Ralf95
Posts: 12
Joined: Mon May 27, 2019 6:01 pm

Re: Possible Bug in 3.4.1

Postby Ralf95 » Sun Jun 09, 2019 4:34 pm

Testfile.data
(48.82 KiB) Downloaded 42 times

User avatar
Vicky@Raise3D
Posts: 5510
Joined: Fri Mar 25, 2016 3:54 am

Re: Possible Bug in 3.4.1

Postby Vicky@Raise3D » Tue Jun 11, 2019 5:26 pm

It seems a possible bug. The software team is currently debugging it. We will have a beta version with this issue fixed soon.
If you have any interest to help us test this version, please let me know. I will PM you the download link.

Ralf95
Posts: 12
Joined: Mon May 27, 2019 6:01 pm

Re: Possible Bug in 3.4.1

Postby Ralf95 » Wed Jun 12, 2019 3:48 am

Dear Vicky,

I can of course test the new version....

User avatar
Vicky@Raise3D
Posts: 5510
Joined: Fri Mar 25, 2016 3:54 am

Re: Possible Bug in 3.4.1

Postby Vicky@Raise3D » Wed Jun 12, 2019 9:44 pm

Thanks for your helping!
PM sent with the download link of beta version.

Ralf95
Posts: 12
Joined: Mon May 27, 2019 6:01 pm

Re: Possible Bug in 3.4.1

Postby Ralf95 » Thu Jun 13, 2019 4:01 pm

thumbs_up.png
thumbs_up.png (36.94 KiB) Viewed 1009 times


Tested some models and it looks llike the failure is gone now.
Good work, good support.....

Thanks...

User avatar
Vicky@Raise3D
Posts: 5510
Joined: Fri Mar 25, 2016 3:54 am

Re: Possible Bug in 3.4.1

Postby Vicky@Raise3D » Thu Jun 13, 2019 6:08 pm

Thanks for your update!

Cotty
Posts: 3
Joined: Thu Jun 20, 2019 12:42 pm

Re: Possible Bug in 3.4.1

Postby Cotty » Thu Jun 20, 2019 5:09 pm

I found a bug that might be related:

when [avoid traveling through holes] is set, the travel from the end of the outer wall path to beginning of the infill path is split into multiple segments when it doesn't need to be. the first segment is very small (~0.1mm) and at the full travel speed. This tiny high speed segment can make the printer to jerk violently if the next travel segment is not mostly parallel, and sometimes causes the X/Y motors skip from the rebound leading to layer shift.


Code: Select all

G1 X139.881 Y195.347 E2369.0472
G0 F9000 X139.781 Y195.337
G0 X138.369 Y194.567
;TYPE:FILL
;WIDTH:0.400
G1 F4800 X138.094 Y194.383 E2369.0637

Ideamaker bug.PNG

User avatar
Vicky@Raise3D
Posts: 5510
Joined: Fri Mar 25, 2016 3:54 am

Re: Possible Bug in 3.4.1

Postby Vicky@Raise3D » Fri Jun 21, 2019 6:33 pm

Would you like to share .idea and .gcode files with us for testing purpose?


Return to “Software”

Who is online

Users browsing this forum: No registered users and 2 guests