Probe not stopping Z travel or home

leonhart8888
Posts: 45
Joined: Tue Jul 07, 2020 12:02 am

Probe not stopping Z travel or home

Postby leonhart8888 » Mon Aug 31, 2020 5:03 am

My probe is acting really strange all of a sudden. Sometimes it works, sometimes it doesn't and then causes my machine to crash in the Z when homing or when touching off at the start of a print.

I've taken the cover off the probe and the LED flashes appropriately depending on where the probe is. I've been pushing the probe with my finger to see how it works (or doesn't). The LED always shows that the probe assembly itself is working, but for some reason the firmware or software doesn't stop the machine and I have to cut power and try again.

This is super annoying. Anyone else encounter this before?

ArtistMonkey
Posts: 2
Joined: Sat Aug 29, 2020 3:57 am

Re: Probe not stopping Z travel or home

Postby ArtistMonkey » Mon Aug 31, 2020 4:08 pm

I am dealing with the z-height not holding over time and eventually the nozzle falls into the print/buildplate. This destroys the print and is tearing up my build plate, I am on an E2 and this is happening on the left nozzle. I have done all the steps to set the height correctly but I can not print even a raft now as the nozzle is not holding its z position. I was able to get about three spools of prints made before this started happening. I have not seen my post approved yet, I submitted one on Friday describing with pictures my issues. I can't find any information on this particular problem. I have tried offset calibration over 4 times and my bed flatness is 0.12.

leonhart8888
Posts: 45
Joined: Tue Jul 07, 2020 12:02 am

Re: Probe not stopping Z travel or home

Postby leonhart8888 » Sat Sep 05, 2020 7:07 pm

I've done a bunch of tests which narrowed down the issue to either the extruder cable, or a cold solder joint on the extruder top PCB.

Raise3D support is sending me a spare cable, but in the mean time I've swapped the right cable with the left cable and it seems to be working alright so far.

I wish Raise3D could implement several things:

a) Stop a homing command through the touchscreen interface rather than killing power
b) Monitor motor current and stop the machine when it crashes rather than continuing to grind into the build plate
c) Ability to manually set the height of the extruder without having to probe home before a print

User avatar
Vicky@Raise3D
Posts: 7389
Joined: Fri Mar 25, 2016 3:54 am

Re: Probe not stopping Z travel or home

Postby Vicky@Raise3D » Wed Sep 09, 2020 1:38 am

1. It can't be stopped immediately with only one command as far as we seen.
2. We will see how to add monitor and stop in future motion board firmware.
3. We need more research on whether it is possible and safe to do this one.

leonhart8888
Posts: 45
Joined: Tue Jul 07, 2020 12:02 am

Re: Probe not stopping Z travel or home

Postby leonhart8888 » Wed Sep 09, 2020 2:25 am

Ok thanks Vicky!


Return to “E2”

Who is online

Users browsing this forum: No registered users and 1 guest