How to disable an extruder for using only one

User avatar
AFTECH
Posts: 34
Joined: Sun Jun 17, 2018 7:52 am
Location: France
Contact:

How to disable an extruder for using only one

Postby AFTECH » Mon Oct 01, 2018 12:31 pm

Hello
This week en i had a big issue with my Pro 2 plus
I had a leak in the left extruder because i didn't tighten enough the nozzle to the throat tube and lots of filament went inside the silicone socket
So i dismantled the hot end but when i wanted to unscrew the throat tuben i've brocken it
I've ordered a new one (100€) and i'm waiting for it this week
I know that when we launch a single extruder print, the other one heat also to the same temperature
Right now i can't mount the brocken hot end so it's imposible to get the red heater and the temperature sensor also mounted.
So is it posible to disconnect these parts and use the printer with only one extuder in place ?

Thanks in advance
Raise 3D Pro 2 +

User avatar
Vicky@Raise3D
Posts: 5634
Joined: Fri Mar 25, 2016 3:54 am

Re: How to disable an extruder for using only one

Postby Vicky@Raise3D » Tue Oct 02, 2018 12:09 am

Set the extruder count to be 1 in printer settings, and take the prob of right nozzle up and fix it, in case it drops off affecting printing.

User avatar
AFTECH
Posts: 34
Joined: Sun Jun 17, 2018 7:52 am
Location: France
Contact:

Re: How to disable an extruder for using only one

Postby AFTECH » Wed Oct 03, 2018 9:08 am

Thanks a lot, next time if i break again a hot end i will be able to use the printer without it
Yesterday morning i've received my new hot end and mounted it.
It's a pity that the throat tube is not sold as spare parts, because it's the failure point of the hot end.
I think that next time i will measure it and procure it in stainless steel.
Raise 3D Pro 2 +

User avatar
AFTECH
Posts: 34
Joined: Sun Jun 17, 2018 7:52 am
Location: France
Contact:

Re: How to disable an extruder for using only one

Postby AFTECH » Fri Feb 15, 2019 3:48 pm

Hello i've just had this problem again
But in the printer settings i didn't found where i can select the number of extruder
In advanced settings there's the indication "number of extruders 2" but i can't modifiy it
And in Ideamaker in the printer settings i've put 1 extruder in number of extruders but when i start a print the 2nd extruder heat at the same temperature as left extruder so if i dismount and fix the heater somewhere it will burn it.
Raise 3D Pro 2 +

User avatar
ocelot27
Posts: 118
Joined: Sat Feb 02, 2019 4:39 pm
Location: Malvern, PA

Re: How to disable an extruder for using only one

Postby ocelot27 » Fri Feb 15, 2019 6:00 pm

I agree - is there any way to prevent an unused extruder from preheating along with the used extruder??? I've set everything I can find to shut off the R extruder but it still preheats along with the L?

markm
Posts: 44
Joined: Wed Feb 06, 2019 7:17 am

Re: How to disable an extruder for using only one

Postby markm » Fri Feb 15, 2019 7:27 pm

I noticed the same thing, both extrudes preheat before the print starts and then the unused one cools down once the print starts. I've tried several things including setting the machine to 1 nozzle, setting the heat for the second nozzle to 0 temp, adjusting static setting lower (only can go down to 180) but it still preheats to 200. Only thing I can figure is that it's the machine firmware's startup routine.

User avatar
Vicky@Raise3D
Posts: 5634
Joined: Fri Mar 25, 2016 3:54 am

Re: How to disable an extruder for using only one

Postby Vicky@Raise3D » Fri Feb 15, 2019 10:35 pm

Sorry, it's my fault. I thought you got a N series printer. But I just read your first post again, that you have mentioned that you have a Pro2.
For Pro2 series printer, both nozzles will be heat up before print starts, so that the filament in nozzles can be heated to soft. If nozzle jogging happens, it won't do harm to nozzles.

robertk925
Posts: 1
Joined: Thu Feb 21, 2019 5:19 am

Re: How to disable an extruder for using only one

Postby robertk925 » Fri Feb 22, 2019 6:37 pm

Vicky, can we request a fix to either the firmware or a workaround for the start G-code to not heat the unused extruder? The unused extruder often will drip filament on the bed or print when it is heated up unnecessarily, so this should be controllable by the user.

User avatar
Vicky@Raise3D
Posts: 5634
Joined: Fri Mar 25, 2016 3:54 am

Re: How to disable an extruder for using only one

Postby Vicky@Raise3D » Fri Feb 22, 2019 10:41 pm

We are going to improve this feature to have the unused nozzle cool down once nozzle purging completes for single-extrude print.

User avatar
ocelot27
Posts: 118
Joined: Sat Feb 02, 2019 4:39 pm
Location: Malvern, PA

Re: How to disable an extruder for using only one

Postby ocelot27 » Sun Feb 24, 2019 5:42 pm

Can the last known position of the hot ends be written to memory so the printer "knows" the positions of the extruders so it doesn't have to do it's little raise lower dance in the beginning? Or if you must toggle the hot ends, why not just sync the extruders so that it can be done cold?
-john

User avatar
Vicky@Raise3D
Posts: 5634
Joined: Fri Mar 25, 2016 3:54 am

Re: How to disable an extruder for using only one

Postby Vicky@Raise3D » Tue Feb 26, 2019 1:42 am

Thanks for your suggestions. I will forward to the developing team to see whether they can achieve this judgement or not.

Slycat
Posts: 12
Joined: Wed Jul 17, 2019 1:18 pm

Re: How to disable an extruder for using only one

Postby Slycat » Wed Jul 17, 2019 1:27 pm

For what it's worth, I've noticed that every first print after powering on heats both hot-ends. I first saw this as an error so I immediately stop the print. After that any file I print, including the same one I just stopped, only heats the hot-end being used.
So maybe this is just a purge for first run.

EDIT: just checked my gcode from this morning's first print, only T0 (left) is called for temp set (M104/M109) but I still got both hot-ends to temp set. Stopped the print, then selected to print the same file, and only T0 heated up.

User avatar
Vicky@Raise3D
Posts: 5634
Joined: Fri Mar 25, 2016 3:54 am

Re: How to disable an extruder for using only one

Postby Vicky@Raise3D » Fri Jul 19, 2019 2:09 am

When the RaiseTouch firmware 1.2.0 or higher version, if the printer is just power on, it will heat up both nozzles for the first print to figure out which nozzle is up and which one is down. Once it has printed something with nozzles, it will record the nozzle activation status then. So next print, it will only heat the nozzle(s) which needs to be heat.

research.caddy
Posts: 2
Joined: Tue Aug 14, 2018 4:48 pm

Re: How to disable an extruder for using only one

Postby research.caddy » Tue Jul 23, 2019 3:19 pm

I just now had to find a way to prevent the right nozzle from heating before a print as I have a broken thermocouple/heat rod which prevents the right nozzle from reaching the target temperature (which then prevents the print from ever starting.)

As a work around, you can manually set the temperature of the nozzle you want to use then, in the utilities menu, manually extrude a little from the preheated nozzle. This allows the system to go through it's 'jog' cycle of the nozzles without heating the nozzle you don't want to print with.

This took me about an hour of playing around with today, but I'm glad I can still use the printer while I'm waiting for replacement parts to arrive.

User avatar
Vicky@Raise3D
Posts: 5634
Joined: Fri Mar 25, 2016 3:54 am

Re: How to disable an extruder for using only one

Postby Vicky@Raise3D » Wed Jul 24, 2019 6:51 pm

It is not able to disable one of the nozzles on touchscreen for the moment. We will add your needs into developing list.
Sorry for the troubles.

pjyarnall
Posts: 50
Joined: Fri Jun 22, 2018 9:29 pm
Location: Canandaigua, NY

Re: How to disable an extruder for using only one

Postby pjyarnall » Sat Aug 10, 2019 10:39 pm

If one disengages the drive pressure screw on the un-needed extruder then it doesn't need to be preheated to do the "dance" on start up. The unused extruder will simply push the filament up when the extruder retracts. You might take that into account when changing the firmware.

The whole issue of controlling the desired extruder and not heating the other is a continuing severe annoyance in the Pro2 - Ideamaker software. Amazing to me that a solution has been lacking.
Pro 2

User avatar
Vicky@Raise3D
Posts: 5634
Joined: Fri Mar 25, 2016 3:54 am

Re: How to disable an extruder for using only one

Postby Vicky@Raise3D » Mon Aug 12, 2019 12:51 am

Sorry for the inconvenience. We have tried our best to avoid unnecessary preheating process. But due to hardware limitation, the first print after power on the printer, still need preheat both nozzles.


Return to “Pro2 Series”

Who is online

Users browsing this forum: No registered users and 2 guests