Slicing issue and exclamation point

Discussions about ideaMaker and other printing software.
Cowski
Posts: 4
Joined: Sat Jun 09, 2018 8:31 pm

Slicing issue and exclamation point

Postby Cowski » Sat Jun 09, 2018 8:51 pm

I hope I'm posting in the right place. If not, please move it at your discretion and let me know. :)

I've been using CURA for some time but finding that the prints on my CR-10 weren't as good as I wanted them to be. So someone suggested giving ideaMaker a go.
I like this software because of the customized supports but I'm running into a couple of issues I was hoping someone could help me with.
1. When I add a STL file to slice, first off it comes in shaded red and with a yellow, triangle exclamation point to the side. How can I find out what the issue is?
exclamation point.jpg
What I see when I add my STL file.
exclamation point.jpg (16.7 KiB) Viewed 259 times

2. This is the very odd one. This picture shows a comparison of ideaMaker vs. CURA -- Why is ideaMaker putting that gap there and that "notch" when that is not in the stl when I designed it?
Comparison.jpg


I also tried Repetier Host and that one came out virtually identical to CURA as well.
I'd like to stick with ideaMaker because of the custom supports and the way this printed out a great first layer for me where CURA could not get the results I was looking for.
Thanks everyone!!

User avatar
Vicky@Raise3D
Posts: 4138
Joined: Fri Mar 25, 2016 3:54 am

Re: Slicing issue and exclamation point

Postby Vicky@Raise3D » Sun Jun 10, 2018 8:34 am

Have you tried with Auto-repair in ideaMaker?
Would you like to share the stl file with us for testing?

User avatar
jmp
Posts: 213
Joined: Mon Mar 21, 2016 12:20 pm

Re: Slicing issue and exclamation point

Postby jmp » Sun Jun 10, 2018 4:15 pm

The big clue is the 363 Non Manifold edges, basically your model has 363 errors in it. With non manifold edges the slicer doesn't really know what the model is supposed to be so it has to guess. In this case Cura's guess matched how you wanted the model but fundamentally this is a modeling issue, not a slicer issue. Go ahead with Vicky's advice as that may work this time but you need to find out what in your modeling is causing bad stl files.
RL Name: Jason Preuss Thingiverse: JMP Youtube:http://youtube.com/c/patterntoprint Website: http://www.patterntoprint.com

Cowski
Posts: 4
Joined: Sat Jun 09, 2018 8:31 pm

Re: Slicing issue and exclamation point

Postby Cowski » Sun Jun 10, 2018 5:33 pm

Thank you for the quick replies!

Tried the Repair and it took the Non-Manifold Edges from 363 down to 85. Tried it again, took it to 29 then 23. But at 23 the model got "deformed". I ctrl-z (thought I'd try it) back to 85, sliced it and it fixed that issue Screenshot below shows the new slice.
Good fill.jpg
Good fill


But the next issue is shown below. This is probably the results of the remaining errors I am getting. Not sure why ideaMaker is picking these out but CURA and Repetier are having no issues with it.
Bad top.jpg
Incorrect slice for top part


Is it common to have errors like this? Or this many? And I will not deny the modeling issue. I designed this in Fusion 360 and it looked okay in there. I'm pretty new to that software as well but learning that as I go.

Who'd thunk the slicer would find issues. I learned a couple of things from these posts!

I've attached the STL file for references. It's a beer bottle holder I'm making for a friend of mine. I got the original design from thingiverse but wanted to modify it so I could make my own changes to it. Hence the issues I'm having with it.
Hopefully someone can help me out. Thanks everyone!!
Beer bottle holder.stl
Beer bottle holder
(3.55 MiB) Downloaded 7 times

User avatar
Vicky@Raise3D
Posts: 4138
Joined: Fri Mar 25, 2016 3:54 am

Re: Slicing issue and exclamation point

Postby Vicky@Raise3D » Mon Jun 11, 2018 7:55 am

Try this option:

Merge Internal Overlapping Parts under Other tab in Advanced Settings.

1.png


As this model has several overlapping structures which cause ideaMaker defines them as non-manifold edges.
The Auto-Repair function calculates based on triangles on model surface which cannot repair all the errors correctly with one try. The options in advanced settings can help some in some cases.

User avatar
Stefan J. Trucker
Posts: 14
Joined: Sat May 26, 2018 7:28 am
Location: Vienna
Contact:

Re: Slicing issue and exclamation point

Postby Stefan J. Trucker » Mon Jun 11, 2018 11:45 am

maybe you add an link to that options when you have the note which tells you that the object is not manifold

I had a similar issue and just use a different software to fix the part because the auto repair did not work and it would have saved me some time if i would have thought of the option in slicing settings
Be creative, be independent, be you!

Cowski
Posts: 4
Joined: Sat Jun 09, 2018 8:31 pm

Re: Slicing issue and exclamation point

Postby Cowski » Mon Jun 11, 2018 11:18 pm

Vicky@Raise3D wrote:Try this option:

Merge Internal Overlapping Parts under Other tab in Advanced Settings.

As this model has several overlapping structures which cause ideaMaker defines them as non-manifold edges.
The Auto-Repair function calculates based on triangles on model surface which cannot repair all the errors correctly with one try. The options in advanced settings can help some in some cases.


Gave your suggestion a try and it seemed to fix my top issue. But now the bottom is broken...very broken. :lol: :lol: :lol: :lol:
It totally inverted the bottle holder area at the bottom.
Not good.jpg
Not good


And yes...I ran repair on it first. It just got worse as I progressed.

Stefan J. Trucker wrote:maybe you add an link to that options when you have the note which tells you that the object is not manifold

I had a similar issue and just use a different software to fix the part because the auto repair did not work and it would have saved me some time if i would have thought of the option in slicing settings


I'm not sure what you mean by a "link to that options when you have the note which tells you that the object is not manifold"

What software did you use to fix the part when auto repair didn't work?

I just find it very weird that CURA and Repetier Host have no issues slicing this. Hell, I even tossed it into CURA 14.07 and it sliced okay in there. Had a different issue but nonetheless it sliced "ok".
It seems ideaMaker is the only one, for me, that's giving me a headache. I know someone at work that has Simplify 3d...I may have him try to slice it to see what happens.

Thanks everyone. Still plugging away. I'm going back to Fusion 360 to see what I can do in there. I'll report back what I find.

Cowski
Posts: 4
Joined: Sat Jun 09, 2018 8:31 pm

Re: Slicing issue and exclamation point

Postby Cowski » Mon Jun 11, 2018 11:36 pm

Well...a quick few clicks in Fusion 360 which allow me to combine components into bodies may have done the trick!
When I designed it, there was a "neck", "handle", "bottom". I did this for reasons within Fusion 360. I combined the 3 to make 1 body, saved it, threw it into ideaMaker. I didn't get any errors, AT ALL but when I sliced it, it still didn't connect up right. Looked virtually the same.
So went back into the setting recommended by Vicky, to "Merge Internal Overlapping Parts" and sliced.
Voila!!
Will it work.jpg
Will it work??


This is ~22 hour print and I like to be at home when it's printing so probably won't get to it till Weds. night because I work from home on Thursdays. If it turns out, I'll post a pic of it!!
Stay tuned!!


Return to “Software”

Who is online

Users browsing this forum: No registered users and 1 guest