Weird Linear Advance Calibration Print

Discussions about ideaMaker and other printing software.
FreedomRules
Posts: 40
Joined: Thu Jan 25, 2018 4:34 pm

Weird Linear Advance Calibration Print

Postby FreedomRules » Thu May 24, 2018 1:42 am

I recently made a branch from ABH 1.1_x_bf that has Linear-Advance 1.5 in it and flashed it. Really didn't make any changes except model and been trying to tweak PID tuning so it will work but no success yet.

My issue is I went to Marlin's site and made a K-Factor test file for 1.5 Linear-Advance. What you see in the image is what it prints. I set the settings for our printers. What I noticed is during printing the retraction movements are extreme. I've run linear advance before on version 1.0. I thought I'd try and create a 1.0 version file and see what it did. There is no difference in the print.

Anyone bored that is running linear advance version 1.5 want to print the k1.5 file and let me know what you get. Anyone have any ideas??

My printer prints all my other files just fine so I don't know if its something in my version of Marlin or if its the calibration generator.
Attachments
K1.0.gcode.txt
Linear_Advance Version 1.0
(260.79 KiB) Downloaded 6 times
K1.5.gcode.txt
Linear_Advance Version 1.5
(13.83 KiB) Downloaded 5 times
IMG_1169.jpg
What prints when using the calibration files.

TDP
Posts: 2
Joined: Fri May 25, 2018 12:52 pm

Re: Weird Linear Advance Calibration Print

Postby TDP » Fri May 25, 2018 12:58 pm

I have not run your Gcode you posted but I did look through it.
The first thing I noticed was the K factor range for the 1.5 version is off. With the old linear advance version, K factors could range from 40 up to 200+.
Now with the new 1.5 version, the expected K factor will be in the range of .01 to 2.
When I do my calibration, when it get near the 2 for K factor it kinda starts to bug out So I can imagine starting at a K factor of 5, like in your Gcode, would cause some undesirable results.

Also, I am running the 1.1.x bugfix verison on our printer with the V1.5 linear advance and it is working fine. My K factors range from .12 to .24.


Return to “Software”

Who is online

Users browsing this forum: No registered users and 3 guests