Start Gcode causing odd results in preview

Discussions about ideaMaker and other printing software.
Snupple
Posts: 2
Joined: Tue Nov 07, 2017 3:12 pm

Start Gcode causing odd results in preview

Postby Snupple » Tue Nov 07, 2017 3:19 pm

Hi, I am trying IM out for my I3 clone and have found that the Start Gcode I use in Slic3r is causing the preview to make a line go off into the far distance.

When I load the gcode up in Octoprint it says it will take over 300m of filament for a small 3cmx4cmx1cm model!

This is the start gcode I am using:

Code: Select all

G91 ; Relative Positioning
G1 Z10 F500 ; Move up 10mm

G28 XY

G90
G1 Y80 X090 F5000 ; Move to middle of bed
M109 S245 ; Heat Nozzle to 245 so distance from bed is accurate
G28 Z
; Heat Up to 245

G29 ; Auto Level Bed
;1 Z5.0 F9000 ;move the head 5mm up for CYA clearance
G92 E0 ;zero the extruded length
M117 Cleaning...;Put Cleaning message on screen
G1 X90 Y3 F4000 ; move half way along the front edge
G92 E0 ; zero the extruded lnegth
G1 Z1 ; move nozzle close to bed
M117 Cleaning ...
;M109 S230 ; heat nozzle to 200 degC and wait until reached
G4 P10000 ; wait 10 seconds for nozzle length to stabilize
G1 E10 ; extrude 10 mm of filament
G1 Z15 F12000 E5 ; move 15 mm up, fast, while extruding 5mm
G91
G1 Y40 F1500
G92 E0 ; reset extruder
M117 Printing...;Put printing message on LCD screen


Example of preview:

Image

User avatar
walshlg
Posts: 1346
Joined: Wed Mar 23, 2016 12:01 pm

Re: Start Gcode causing odd results in preview

Postby walshlg » Tue Nov 07, 2017 8:45 pm

try just a bit at a time to isolate the problem

User avatar
Vicky@Raise3D
Posts: 4138
Joined: Fri Mar 25, 2016 3:54 am

Re: Start Gcode causing odd results in preview

Postby Vicky@Raise3D » Wed Nov 08, 2017 1:51 am

Saw code G91 in the end of your starting code, which defines the coordinate to be relative position.
Please add G90 before G92 E0 which will define the coordinate to be absolute position and see whether the preview goes normal.

Code: Select all

G91
G1 Y40 F1500
G90
G92 E0 ; reset extruder
M117 Printing...;Put printing message on LCD screen

Snupple
Posts: 2
Joined: Tue Nov 07, 2017 3:12 pm

Re: Start Gcode causing odd results in preview

Postby Snupple » Mon Nov 13, 2017 12:08 pm

Yay, that did it - thanks!


Return to “Software”

Who is online

Users browsing this forum: No registered users and 2 guests